summaryrefslogtreecommitdiff
path: root/tests/libXrender/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libXrender/Makefile.am')
-rw-r--r--tests/libXrender/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/libXrender/Makefile.am b/tests/libXrender/Makefile.am
new file mode 100644
index 0000000..3865a5c
--- /dev/null
+++ b/tests/libXrender/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Copyright (c) 2013, Oracle and/or its affiliates. All rights reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+#
+
+noinst_PROGRAMS = XRenderQueryFilters
+
+noinst_HEADERS = xhiv-Xrender.h
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/include
+AM_CFLAGS = $(CWARNFLAGS) $(LIBXRENDER_CFLAGS)
+LDADD = -L$(top_builddir)/src -lXhiv $(LIBXRENDER_LIBS)
+
+TESTS = $(noinst_PROGRAMS)
+