summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2009-02-03 10:28:21 -0500
committerAdam Jackson <ajax@redhat.com>2009-02-03 10:28:21 -0500
commit94b814a675a07d28e6c81a878656a64c6c0b3770 (patch)
treed63d3650453ecebd8847bac3caf4f0244654f059 /configure.ac
parent7eb3820f1fa09e5d411de9e02ef6572cbc4809fe (diff)
Add the standard X warning flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c7cb05..7ac9763 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,12 @@ if test "x$XSERVER_LIBPCIACCESS" = xyes; then
fi
AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
-CFLAGS="$CFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
+# blah, should be XORG_CWARNFLAGS
+if test "x$GCC" = xyes ; then
+ CWARNFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wold-style-definition -Wbad-function-cast -Wdeclaration-after-statement"
+fi
+
+CFLAGS="$CFLAGS $CWARNFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
INCLUDES="$XORG_INCS -I${sdkdir} "'-I$(top_srcdir)/src -I$(prefix)/include'
AC_SUBST([CFLAGS])
AC_SUBST([INCLUDES])