summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..07605b6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,17 @@
+AUTOMAKE_OPTIONS = foreign
+
+sbin_PROGRAMS = vbetool
+
+vbetool_LDADD = $(libdir)/libpci.a
+
+man_MANS = vbetool.1
+vbetool_SOURCES = vbetool.c $(x86)
+noinst_HEADERS = vbetool.h
+
+EXTRA_DIST = vbetool.1 LRMI
+
+maintainer-clean-local:
+ $(RM) Makefile.in aclocal.m4 config.h.in stamp-h.in configure
+
+AM_CFLAGS = -g -Wall -pedantic -std=gnu99
+AM_LDFLAGS = -lz -lx86