summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2009-12-17 15:08:53 +1000
committerDave Airlie <airlied@redhat.com>2009-12-17 15:09:55 +1000
commitf18d76a58c47bc03fee672767eac33d1bc08de45 (patch)
treecc466e9aacffaf37cdaeb7f0e5c73e6b1993cca0 /Makefile.am
parente08c8ff59282461683be1a3a3d2d055b8dd89ddc (diff)
radeon/avivotool: automake/autoconfisizeradeontool-1.6.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9915a16
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,33 @@
+# Copyright 2009 Dave Airlie
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = radeontool avivotool
+
+AM_CFLAGS = $(LIBPCIACCESS_CFLAGS)
+
+radeontool_SOURCES = radeontool.c radeon_reg.h xf86i2c.h radeon.h radeon_chipinfo_gen.h
+avivotool_SOURCES = avivotool.c atom.c xf86i2c.c atombios_tables.c \
+ atombios.h atom.h atom-bits.h radeon.h radeon_chipinfo_gen.h \
+ atom-types.h kernel-compat.h ObjectID.h atom-names.h
+
+radeontool_LDADD = $(LIBPCIACCESS_LIBS)
+avivotool_LDADD = $(LIBPCIACCESS_LIBS)