summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Deucher <alexdeucher@gmail.com>2011-01-26 15:04:58 -0500
committerDave Airlie <airlied@redhat.com>2011-02-08 05:58:35 +1000
commit3b05824e9d5fa58fcba838b34fcabcb1ee6a1b89 (patch)
treee823452a0988908ea9758a79b8afdc0ccb2c5511 /Makefile.am
parent08c93b41a8119c99202be1962c83bf8da92b9ee8 (diff)
add radeonreg program
simple reg dumper for different families. radeonreg regs <set> <set> radeon - r128, r1xx-r4xx avivo - r5xx, rs600/690/740, r600, rv610/630/670 dce3 - rv620/635/770/710/730/740, rs780/880 dce4 - evergreen dce5 - ni Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9915a16..8222acc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@
AUTOMAKE_OPTIONS = foreign
-bin_PROGRAMS = radeontool avivotool
+bin_PROGRAMS = radeontool avivotool radeonreg
AM_CFLAGS = $(LIBPCIACCESS_CFLAGS)
@@ -28,6 +28,10 @@ radeontool_SOURCES = radeontool.c radeon_reg.h xf86i2c.h radeon.h radeon_chipinf
avivotool_SOURCES = avivotool.c atom.c xf86i2c.c atombios_tables.c \
atombios.h atom.h atom-bits.h radeon.h radeon_chipinfo_gen.h \
atom-types.h kernel-compat.h ObjectID.h atom-names.h
+radeonreg_SOURCES = radeonreg.c \
+ radeon.h radeon_chipinfo_gen.h \
+ kernel-compat.h
radeontool_LDADD = $(LIBPCIACCESS_LIBS)
avivotool_LDADD = $(LIBPCIACCESS_LIBS)
+radeonreg_LDADD = $(LIBPCIACCESS_LIBS)