summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2015-12-10 16:58:24 -0800
committerJason Ekstrand <jason.ekstrand@intel.com>2015-12-10 18:29:36 -0800
commitd5c9955d3eaa7311e2b2350b6964bae516c7b7b2 (patch)
tree401e4378dd9909f9010f076d026a77e515170be5 /configure.ac
parent8beea9d45b5879ea3dbd9c0e48f0c0eb2451f380 (diff)
parent78b81be627734ea7fa50ea246c07b0d4a3a1638a (diff)
Merge remote-tracking branch 'mesa-public/master' into vulkan
This pulls in nir_intrinsic_load/store changes and the switch of all uniforms in i965 to bytes. This accounts for the Vulkan changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ebea7fcb61a..c26dbf2e126 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,13 @@ if test "x$GCC" = xyes -a "x$acv_mesa_CLANG" = xno; then
fi
fi
+dnl We don't support building Mesa with Sun C compiler
+dnl https://bugs.freedesktop.org/show_bug.cgi?id=93189
+AC_CHECK_DECL([__SUNPRO_C], [SUNCC=yes], [SUNCC=no])
+if test "x$SUNCC" = xyes; then
+ AC_MSG_ERROR([Building with Sun C compiler is not supported, use GCC instead.])
+fi
+
dnl Check for compiler builtins
AX_GCC_BUILTIN([__builtin_bswap32])
AX_GCC_BUILTIN([__builtin_bswap64])