summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-11-22 22:05:01 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-11-23 12:08:04 +0000
commitb89d1b2ccf16c0bee3708560b69e99b6dbb212f0 (patch)
tree7a6ee2f30f76d2cddc55fd31d42f33acd9823a09 /configure.ac
parentb9b0a1f58e41ba4027a16300393835dc8c632f50 (diff)
configure.ac: default to disabled dri3 when --disable-dri is set
Not too long ago, the dri3 code was living in src/glx, which in itself was guarded by HAVE_DRI_GLX. As the name suggests we didn't dive into the folder when dri was disabled, thus we missed that dri3 does not consider/honour --enable-dri. Cc: mesa-stable@lists.freedesktop.org Fixes: 6bd9ba7d074 "loader: Add dri3 helper" Cc: Pali Rohár <pali.rohar@gmail.com> Reported-by: Pali Rohár <pali.rohar@gmail.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 120c93e7e73..40168715fc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -767,6 +767,11 @@ linux*)
dri3_default=no
;;
esac
+
+if test "x$enable_dri" = xno; then
+ dri3_default=no
+fi
+
AC_ARG_ENABLE([dri3],
[AS_HELP_STRING([--enable-dri3],
[enable DRI3 @<:@default=auto@:>@])],