summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2016-02-05 15:21:11 -0800
committerJason Ekstrand <jason.ekstrand@intel.com>2016-02-05 15:21:11 -0800
commit9401516113152ea2a571dc1103a2fa7ce68d4ee8 (patch)
tree2472a42bd85a3d3b9697be9235c029099c3d575d /configure.ac
parent741744f691d6ef63e9f9a4c03136f969f2ffb0bf (diff)
parent5b51b2e00013af70072106e9d34905326fc357fc (diff)
Merge remote-tracking branch 'mesa-public/master' into vulkan
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a18080d4ce5..e3d721d93aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2161,7 +2161,12 @@ gallium_require_drm_loader() {
fi
}
+dnl This is for Glamor. Skip this if OpenGL is disabled.
require_egl_drm() {
+ if test "x$enable_opengl" = xno; then
+ return 0
+ fi
+
case "$with_egl_platforms" in
*drm*)
;;