summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:42 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:42 -0500
commit732ae92882383b33384791c2e9136a54e0fd06f3 (patch)
treecb4f654b56e3a81105545c83df3213ae979bf6a5 /Makefile.am
parente56fa06624dc240dbe8d3e127cc3b65da580fe6e (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 14bebfc..e6c6632 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,3 +29,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xrandr.pc
EXTRA_DIST = xrandr.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog