summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb40a36..b59d81b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,17 @@ AM_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([foreign dist-bzip2 -Wall -Werror])
AM_MAINTAINER_MODE([enable])
+AC_CANONICAL_HOST
+
+case "$host" in
+ amd64*|x86_64*)
+ WIXL_ARCH="x64"
+ ;;
+ *)
+ WIXL_ARCH="x86"
+ ;;
+esac
+AC_SUBST(WIXL_ARCH)
LT_INIT
AC_PROG_CXX