summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..8f54fc6
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,25 @@
+# LDFLAGS:
+# -module free module name specification
+# -avoid-version omit module version in file name
+
+# Driver name
+DEFS += -DDRIVER_NAME=@DRIVER_NAME@
+
+# Uncomment for debug messages compilation
+# Set your required debug level:
+# 0: driver init/finalize, pointer on/off etc
+# 1: button events
+# 2: motion/proximity events
+# 3: driver protocol
+# 4: packet dump, transforms, side-btns resolving etc
+# 5: functions entry/return
+#DEFS += -DDEBUG -DDEBUG_LEVEL=3
+
+#
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
+@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version
+@DRIVER_NAME@_drv_ladir = @inputdir@
+
+@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c @DRIVER_NAME@.h