summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorArun Raghavan <arun@osg.samsung.com>2016-10-03 10:58:09 +0530
committerArun Raghavan <arun@arunraghavan.net>2016-10-03 11:01:24 +0530
commit4de66632d79ef40cdc81701203c3e4c3cfb6371e (patch)
tree18f75d07680fd821994e0c68ab0c16c1a219900c /meson.build
parentd00aa0c1ad4556d512124d4c5c1e8c639d589560 (diff)
meson: Enable Orc in build
Top-level meson.build code updated from gst-plugins-good.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d7d28f437..c47a8b47c 100644
--- a/meson.build
+++ b/meson.build
@@ -97,7 +97,6 @@ core_conf.set('GST_API_VERSION', '"@0@"'.format(api_version))
core_conf.set('GST_INSTALL_PLUGINS_HELPER', '"/FIXME"')
core_conf.set('GST_DATADIR', '"/FIXME"')
core_conf.set('GST_LICENSE', '"LGPL"')
-core_conf.set('DISABLE_ORC', 1)
# FIXME: These should be configure options
core_conf.set('DEFAULT_VIDEOSINK', '"autovideosink"')
core_conf.set('DEFAULT_AUDIOSINK', '"autoaudiosink"')
@@ -162,13 +161,18 @@ orcc_args = []
if get_option('use_orc') != 'no'
need_orc = get_option('use_orc') == 'yes'
# Used by various libraries/elements that use Orc code
+ orc_dep = dependency('orc-0.4', version : '>= 0.4.17', required : need_orc)
orcc = find_program('orcc', required : need_orc)
- if orcc.found()
+ if orc_dep.found() and orcc.found()
have_orcc = true
orcc_args = [orcc, '--include', 'glib.h']
+ core_conf.set('HAVE_ORC', 1)
else
message('Orc Compiler not found, will use backup C code')
+ core_conf.set('DISABLE_ORC', 1)
endif
+else
+ core_conf.set('DISABLE_ORC', 1)
endif
subdir('gst-libs')