summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Manley <will@williammanley.net>2014-11-03 12:47:18 +0000
committerWim Taymans <wtaymans@redhat.com>2015-03-14 13:23:40 +0100
commitccd4472e2aaa5315873461c689febd98880879d0 (patch)
tree57047a0e71dea1e6f60dce8e1272a7ccd633b368 /configure.ac
parent8328eab2dea1bdf5e6180f668aed2b83d203f1c4 (diff)
Add test_that_multisocketsink_and_socketsrc_preserve_meta
This test is in a seperate commit to the previous two because it depends on and tests the functionality in both.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f60dc0af6..f3dab3d27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -703,6 +703,12 @@ AG_GST_CHECK_FEATURE(VORBIS, [Xiph Vorbis audio codec], vorbis, [
AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0 vorbisenc >= 1.0)
])
+dnl *** gio-unix-2.0 for tests/check/pipelines/tcp.c ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_GIO_UNIX_2_0, true)
+AG_GST_CHECK_FEATURE(GIO_UNIX_2_0, [glib GIO unix], gio-unix-2.0, [
+ AG_GST_PKG_CHECK_MODULES(GIO_UNIX_2_0, gio-unix-2.0 >= 2.24)
+])
+
if test "x$HAVE_VORBIS" = "xyes"; then
ac_cflags_save="$CFLAGS"
AC_COMPILE_IFELSE([