summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2015-12-17 13:39:01 +0100
committerSebastian Dröge <sebastian@centricular.com>2015-12-17 13:39:01 +0100
commitaadefefba88afe4acbe64454650f24e7ce7c8d70 (patch)
treecac26b5b7d6908cba7e409968246a3071495d342 /configure.ac
parent60bad4815db966a8e4f69e333203a995e38e0159 (diff)
configure: Don't use AG_GST_CHECK_FEATURE for checking for gio-unix-2.0
It's meant to be used for external plugins that can then all be disabled via --disable-external. gio-unix-2.0 however is just an optional dependency for the TCP unit test. Also when using AG_GST_CHECK_FEATURE like this, in the --disable-external part there needs to be an AM_CONDITIONAL for the feature with FALSE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 854602329..5e7ea8578 100644
--- a/configure.ac
+++ b/configure.ac
@@ -704,12 +704,6 @@ AG_GST_CHECK_FEATURE(VORBIS, [Xiph Vorbis audio codec], vorbis, [
AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0 vorbisenc >= 1.0)
])
-dnl *** gio-unix-2.0 for tests/check/pipelines/tcp.c ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_GIO_UNIX_2_0, true)
-AG_GST_CHECK_FEATURE(GIO_UNIX_2_0, [glib GIO unix], gio-unix-2.0, [
- AG_GST_PKG_CHECK_MODULES(GIO_UNIX_2_0, gio-unix-2.0 >= 2.24)
-])
-
if test "x$HAVE_VORBIS" = "xyes"; then
ac_cflags_save="$CFLAGS"
AC_COMPILE_IFELSE([
@@ -751,6 +745,12 @@ AM_CONDITIONAL(HAVE_FT2, test "x$HAVE_FT2" = "xyes")
AC_SUBST(FT2_CFLAGS)
AC_SUBST(FT2_LIBS)
+dnl *** gio-unix-2.0 for tests/check/pipelines/tcp.c ***
+PKG_CHECK_MODULES(GIO_UNIX_2_0, gio-unix-2.0 >= 2.24,
+ HAVE_GIO_UNIX_2_0="yes",
+ HAVE_GIO_UNIX_2_0="no")
+AM_CONDITIONAL(USE_GIO_UNIX_2_0, test "x$HAVE_GIO_UNIX_2_0" = "xyes")
+
dnl *** finalize CFLAGS, LDFLAGS, LIBS
dnl Overview: