summaryrefslogtreecommitdiff
path: root/gst-libs/gst/mpegts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/mpegts/meson.build')
-rw-r--r--gst-libs/gst/mpegts/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst-libs/gst/mpegts/meson.build b/gst-libs/gst/mpegts/meson.build
index 6c3758e0a..f017e86a0 100644
--- a/gst-libs/gst/mpegts/meson.build
+++ b/gst-libs/gst/mpegts/meson.build
@@ -20,6 +20,7 @@ install_headers(mpegts_headers, subdir : 'gstreamer-1.0/gst/mpegts')
mpegts_enums = gnome.mkenums_simple('gstmpegts-enumtypes',
sources : mpegts_headers,
+ body_prefix : '#ifdef HAVE_CONFIG_H\n#include "config.h"\n#endif',
header_prefix : '#include <gst/mpegts/mpegts-prelude.h>',
decorator : 'GST_MPEGTS_API',
install_header: true,
@@ -31,7 +32,7 @@ gen_sources = [mpegtsenumtypes_h]
gstmpegts = library('gstmpegts-' + api_version,
mpegts_sources, mpegts_enums,
- c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API', '-DBUILDING_GST_MPEGTS'],
include_directories : [configinc, libsinc],
version : libversion,
soversion : soversion,