summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2018-02-18 11:37:18 +0200
committerSebastian Dröge <sebastian@centricular.com>2018-02-18 11:37:18 +0200
commit34f0d9868ade5bcc153d573d2fc18ac8a8245e86 (patch)
treef6ab667ef3977a7cdb933662a66f4592bcd8be79 /configure.ac
parent0cad51d96c21da32c86c20c6f41f85e02dc4111d (diff)
configure: Add configure check for gmodule-no-export-2.0
This is needed for all code using the g_module_*() API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f53d9b7e..367492abb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,9 @@ dnl GLib is required
GLIB_REQ=2.40.0
AG_GST_GLIB_CHECK([$GLIB_REQ])
+dnl Needed by plugins that use g_module_*() API
+PKG_CHECK_MODULES(GMODULE_NO_EXPORT, gmodule-no-export-2.0)
+
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)
AG_GST_CHECK_GST($GST_API_VERSION, [$GST_REQ], yes)