summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean DuBois <sean@siobud.com>2017-06-27 22:50:41 +0000
committerEdward Hervey <bilboed@bilboed.com>2017-12-15 15:44:17 +0100
commit1c583fd27b8625482d71f6af2acd60a9e8ac53bb (patch)
tree5069e60d9ee8d8c86d1588fc809471a247fb054d /configure.ac
parentf2dac588dcd7d566252f2651912c1db75d873660 (diff)
Add aom plugin with av1enc and av1dec element
https://bugzilla.gnome.org/show_bug.cgi?id=784160
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f60701c13..9a401e801 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2131,6 +2131,12 @@ AG_GST_CHECK_FEATURE(ASSRENDER, [ASS/SSA renderer], assrender, [
AC_SUBST(ASSRENDER_CFLAGS)
AC_SUBST(ASSRENDER_LIBS)
+dnl *** AOM ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_AOM, true)
+AG_GST_CHECK_FEATURE(AOM, [AV1 encoder/decoder], aom, [
+ AG_GST_PKG_CHECK_MODULES(AOM, aom)
+])
+
dnl *** vo-amrwbenc ***
translit(dnm, m, l) AM_CONDITIONAL(USE_VOAMRWBENC, true)
AG_GST_CHECK_FEATURE(VOAMRWBENC, [vo-amrwbenc library], vo-amrwbenc, [
@@ -3435,6 +3441,7 @@ dnl not building plugins with external dependencies,
dnl but we still need to set the conditionals
AM_CONDITIONAL(USE_ASSRENDER, false)
+AM_CONDITIONAL(USE_AOM, false)
AM_CONDITIONAL(USE_VOAMRWBENC, false)
AM_CONDITIONAL(USE_VOAACENC, false)
AM_CONDITIONAL(USE_BS2B, false)
@@ -3760,6 +3767,7 @@ tests/icles/Makefile
ext/voamrwbenc/Makefile
ext/voaacenc/Makefile
ext/assrender/Makefile
+ext/aom/Makefile
ext/bs2b/Makefile
ext/bz2/Makefile
ext/chromaprint/Makefile