summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2013-11-08 20:14:59 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-11-10 11:35:00 +0000
commit922a8bab89c1a5970db61670aaee21e827652bc2 (patch)
tree84aff8eb94c0a45e92cb285bf31db4e5067172e0 /configure.ac
parent7b0771180dc9bb7276a473db5663f41b5929199b (diff)
configure: Use proper variables set by PKG_CHECK_MODULES
$DRI_CFLAGS does not actually exist. The PKG_CHECK_MODULES call creates a $DRI1_CFLAGS variable instead. This doesn't break often because "recent" versions of xorg-server.pc indirectly depend on xf86driproto.pc thus bringing in the required CFLAGS through $XORG_CFLAGS. Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=490342 Signed-off-by: Rémi Cardona <remi@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index eb20807a..539ad9bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,8 +396,8 @@ if test "x$enable_dri" != "xno" -a "x$UMS" = "xyes"; then
PKG_CHECK_MODULES(DRI1, [xf86driproto], [DRI1="yes"], [DRI1="no"])
save_CFLAGS="$CFLAGS"
save_CPPFLAGS="$CPPFLAGS"
- CFLAGS="$CFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
- CPPFLAGS="$CPPFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
+ CFLAGS="$CFLAGS $XORG_CFLAGS $DRI1_CFLAGS $DRM_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS $DRI1_CFLAGS $DRM_CFLAGS"
AC_CHECK_HEADERS([dri.h sarea.h dristruct.h], [DRI1="yes"], [DRI1="no"],
[/* for dri.h */
#include <xf86str.h>
@@ -440,7 +440,7 @@ if test "x$enable_dri" != "xno"; then
AC_DEFINE_DIR(DRI_DRIVER_PATH, dridriverdir, [Default DRI2 driver path])
if test "x$DRI2" != "xno"; then
save_CFLAGS=$CFLAGS
- CFLAGS="$XORG_CFLAGS $DRM_CFLAGS $DRI_CFLAGS $DRI2_CFLAGS"
+ CFLAGS="$XORG_CFLAGS $DRM_CFLAGS $DRI1_CFLAGS $DRI2_CFLAGS"
AC_CHECK_HEADERS([dri2.h], DRI2="yes", DRI2="no", [
#include <dixstruct.h>
#include <drm.h>