summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-05-29 12:13:36 +0100
committerJose Fonseca <jfonseca@vmware.com>2015-05-29 12:17:16 +0100
commit0ad15e55bfbca3d6b829b985f9e7ea7e3e69bc61 (patch)
treee1efb7be08ab6bbd30c29d8363a3f9eee3d69778 /configure.ac
parent9119cd7d2c959e437c40c86f214d08dc198bfa69 (diff)
configure.ac: Link mcdisassembler component.
gallivm now depends on it. And depending on particular LLVM version / configure options, the build can fail without this change due to undefined reference to `LLVM*Disasm*' symbols. Trivial.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e49473b0f7..d32aa2492c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1921,7 +1921,7 @@ if test "x$enable_gallium_llvm" = xyes; then
AC_MSG_ERROR([LLVM $LLVM_REQUIRED_VERSION_MAJOR.$LLVM_REQUIRED_VERSION_MINOR or newer is required])
fi
- LLVM_COMPONENTS="engine bitwriter mcjit"
+ LLVM_COMPONENTS="engine bitwriter mcjit mcdisassembler"
if test "x$enable_opencl" = xyes; then
llvm_check_version_for "3" "5" "0" "opencl"