summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSeif Lotfy <seif@lotfy.com>2013-03-11 01:17:28 +0100
committerSeif Lotfy <seif@lotfy.com>2013-03-11 01:17:28 +0100
commitd1ce0271663c71c1e069095880769bdcf3fa0691 (patch)
treeff167e8716fa7ad7717cd04f7dfc638d8b3a485e /configure.ac
parent7eaf5742364959d4e2012b047c29c04c7dc86e50 (diff)
Make gobject-introspection support optional (enabled by default)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index deb390b2..d6ec0d5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,9 +195,15 @@ AS_IF([test "x$enable_docs" != "xno"], [
AM_CONDITIONAL(ENABLE_DOCS, test "x$found_valadoc" = "xyes" -a "x$found_gtkdoc_scan" = "xyes")
-AM_CONDITIONAL([HAVE_INTROSPECTION], [test "x$enable_vala" = "xyes"])
-# this will set HAVE_INTROSPECTION
-GOBJECT_INTROSPECTION_REQUIRE([1.30])
+AC_ARG_ENABLE([introspection],
+ AS_HELP_STRING([--disable-introspection], [Enable Introspection]),
+ [enable_introspection=$enableval],[enable_introspection="yes"])
+AM_CONDITIONAL([HAVE_INTROSPECTION], [test "x$enable_introspection" != "xno"])
+
+if test "x$enable_introspection" != "xno"; then
+ # this will set HAVE_INTROSPECTION
+ GOBJECT_INTROSPECTION_REQUIRE([1.30])
+fi
#################################################
# Ontology parsing dependencies
@@ -229,14 +235,15 @@ cat <<EOF
${PACKAGE}-${VERSION}
Build environment
- Install Prefix: ${prefix}
+ Install Prefix: ${prefix}
Optional dependencies
- fts++: ${enable_fts}
- dee-icu: ${with_dee_icu}
+ fts++: ${enable_fts}
+ dee-icu: ${with_dee_icu}
Other build options:
- SQL debugging: ${explain_queries}
- libzeitgeist docs: ${enable_docs}
+ SQL debugging: ${explain_queries}
+ libzeitgeist docs: ${enable_docs}
+ GObject Introspection: ${enable_introspection}
EOF