summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Staudinger <robsta@linux.intel.com>2012-01-23 14:47:40 +0100
committerRob Staudinger <robsta@linux.intel.com>2012-01-23 14:47:40 +0100
commitc041171f399d7b526543f791849199478c30173f (patch)
tree3400588116a7c4b393580a40d58a8153166d9150 /Makefile.am
parentb2d907bb744a242886277c5f8af28e063c61ffb1 (diff)
build: Run integration tests only when requested
Automatic integration tests require salut and gabble up and running on the respective system. No longer attempt to run those tests unconditionally, but only when requested using --enable-integration-tests at configure time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e996ab0..4209d44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
ACLOCAL_AMFLAGS = -I build
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docs --disable-silent-rules
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-silent-rules \
+ --enable-gtk-doc \
+ --enable-integration-tests \
+ $(NULL)
SUBDIRS = ytstenut docs tests examples