summaryrefslogtreecommitdiff
path: root/hw/xquartz/xpr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xquartz/xpr/Makefile.am')
-rw-r--r--hw/xquartz/xpr/Makefile.am33
1 files changed, 2 insertions, 31 deletions
diff --git a/hw/xquartz/xpr/Makefile.am b/hw/xquartz/xpr/Makefile.am
index 41f2b8655..e74580f73 100644
--- a/hw/xquartz/xpr/Makefile.am
+++ b/hw/xquartz/xpr/Makefile.am
@@ -1,4 +1,4 @@
-bin_PROGRAMS = Xquartz
+noinst_LTLIBRARIES = libXquartzXpr.la
AM_CFLAGS = $(XSERVER_CFLAGS) $(DIX_CFLAGS)
AM_CPPFLAGS = \
@@ -6,7 +6,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/miext \
-I$(top_srcdir)/miext/rootless
-Xquartz_SOURCES = \
+libXquartzXpr_la_SOURCES = \
appledri.c \
dri.c \
xprAppleWM.c \
@@ -18,36 +18,7 @@ Xquartz_SOURCES = \
x-hook.c \
x-list.c
-Xquartz_LDADD = \
- $(top_builddir)/hw/xquartz/libXquartz.la \
- $(top_builddir)/dix/dixfonts.lo \
- $(top_builddir)/miext/rootless/librootless.la \
- $(DARWIN_LIBS) $(XSERVER_LIBS) $(XSERVER_SYS_LIBS) -lXplugin
-
-Xquartz_LDFLAGS = \
- -XCClinker -Objc \
- -Wl,-u,_miDCInitialize \
- -Wl,-framework,Carbon \
- -L/System/Library/Frameworks/OpenGL.framework/Libraries -lGL \
- -Wl,-framework,OpenGL \
- -Wl,-framework,Cocoa \
- -Wl,-framework,CoreAudio \
- -Wl,-framework,IOKit
-
-appmandir = $(APP_MAN_DIR)
-appman_PRE = Xquartz.man.pre
-appman_PROCESSED = $(appman_PRE:man.pre=man)
-appman_DATA = $(appman_PRE:man.pre=@APP_MAN_SUFFIX@)
-
-CLEANFILES = $(appman_PROCESSED) $(appman_DATA)
-
-include $(top_srcdir)/cpprules.in
-
-.man.$(APP_MAN_SUFFIX):
- cp $< $@
-
EXTRA_DIST = \
- Xquartz.man.pre \
dri.h \
dristruct.h \
appledri.h \