summaryrefslogtreecommitdiff
path: root/hw/kdrive/vesa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/kdrive/vesa/Makefile.am')
-rw-r--r--hw/kdrive/vesa/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hw/kdrive/vesa/Makefile.am b/hw/kdrive/vesa/Makefile.am
index ac50d2bf5..ec35c1e2b 100644
--- a/hw/kdrive/vesa/Makefile.am
+++ b/hw/kdrive/vesa/Makefile.am
@@ -19,6 +19,10 @@ libvesa_a_SOURCES = \
Xvesa_SOURCES = \
vesainit.c
+if GLX
+Xvesa_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+endif
+
Xvesa_LDADD = \
libvesa.a \
@KDRIVE_LIBS@