summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPovilas Kanapickas <povilas@radix.lt>2020-12-19 03:12:38 +0200
committerPovilas Kanapickas <povilas@radix.lt>2020-12-19 03:16:16 +0200
commit2ea48952a161bad060838ee79eb177f6d382ace6 (patch)
treeda6525a4d01112197531afcc4ed93326defe16f0 /meson.build
parent4ea8edb40c81506ed9450abfcad64b61b5062038 (diff)
Remove evdev-based test device implementation
evdev driver is unreliable for testing because with input thread there is race condition between input event submission and the reaction by the X server. The inputtest driver has the required synchronization capabilities.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 0 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index d9db502..f0bf895 100644
--- a/meson.build
+++ b/meson.build
@@ -61,13 +61,11 @@ xorg_gtest_sources = files(
'gtest/include/xorg/gtest/xorg-gtest-xserver.h',
'gtest/include/xorg/gtest/inputtest/xorg-gtest-device.h',
'gtest/include/xorg/gtest/inputtest/xorg-gtest-valuators.h',
- 'gtest/include/xorg/gtest/evemu/xorg-gtest-device.h',
'gtest/include/xorg/gtest/xorg-gtest.h',
'gtest/src/defines.h',
'gtest/src/xorg-gtest_main.cpp',
'gtest/src/environment.cpp',
- 'gtest/src/device.cpp',
'gtest/src/process.cpp',
'gtest/src/test.cpp',
'gtest/src/inputtest-device.cpp',
@@ -122,14 +120,6 @@ test('test-process',
),
is_parallel: false,
)
-test('test-device',
- executable('test-device',
- 'gtest/test/device-test.cpp',
- dependencies: dep_xorg_gtest,
- install: false,
- ),
- is_parallel: false,
-)
executable('xserver-test-helper',
'gtest/test/xserver-test-helper.cpp',
install: false)
@@ -164,8 +154,6 @@ common_sources = files(
'tests/common/xorg-conf.h',
'tests/common/helpers.cpp',
'tests/common/helpers.h',
- 'tests/common/device-interface.cpp',
- 'tests/common/device-interface.h',
'tests/common/device-inputtest-interface.cpp',
'tests/common/device-inputtest-interface.h',
'tests/common/video-driver-test.h',