summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-02-25 10:27:08 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-03-10 09:41:59 +0000
commit8f6a67d3144a8b5032e8fa19d424b0cea2e6d275 (patch)
tree5c778753ab5a78faa476956132c8690442e9a327 /meson.build
parenta657dd0b45121735b2f80afa1e5e4940979d89ad (diff)
meson.build: install the protocol .txt files in doc
This now matches the autotools installation Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index feb5ae9..5f3622a 100644
--- a/meson.build
+++ b/meson.build
@@ -66,6 +66,22 @@ foreach pc : pcs
)
endforeach
+
+docs = files('compositeproto.txt',
+ 'damageproto.txt',
+ 'dri2proto.txt',
+ 'dri3proto.txt',
+ 'fixesproto.txt',
+ 'PM_spec',
+ 'presentproto.txt',
+ 'randrproto.txt',
+ 'renderproto.txt',
+ 'resproto.txt',
+ 'xv-protocol-v2.txt')
+install_data(docs,
+ install_dir: get_option('datadir') / 'doc' / 'xorgproto')
+
+
if get_option('legacy') == true
legacy_pcs = [
'evieproto',