summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRan Benita <ran234@gmail.com>2012-10-24 23:27:40 +0200
committerRan Benita <ran234@gmail.com>2012-10-24 23:27:40 +0200
commitc1c1b720b0df5e348c812990d5e43d71f2847f06 (patch)
treee161ee4a998647072085e5e8ffb4d95aba23f9e9 /Makefile.am
parent6f093ad56b88488b95dc8bb543be89b7da9c25ee (diff)
test: add key processing benchmark
This runs a bunch of random keys against xkb_state_update_key() and xkb_state_key_get_one_sym(), in a fairly unintelligent way. It might be nice to check when modifying this code path, or changing it, to see things haven't slowed down considerably. However, given the numbers this benchmark gives, it is pretty clear that we are not going to be the bottleneck for anything. So this can more-or-less be ignored. Incidentally, this also turned out to be a poor man's fuzzer, because it turned up the fix in the previous commit. Maybe we should consider beefing it up with an actual 'break stuff' intention and running it as part of 'make check'. Signed-off-by: Ran Benita <ran234@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c08bca1..48b8856 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,12 +156,14 @@ test_log_LDADD = $(TESTS_LDADD)
test_interactive_LDADD = $(TESTS_LDADD)
test_rmlvo_to_kccgst_LDADD = $(TESTS_LDADD)
test_print_compiled_keymap_LDADD = $(TESTS_LDADD)
+test_bench_key_proc_LDADD = $(TESTS_LDADD) -lrt
check_PROGRAMS = \
$(TESTS) \
test/interactive \
test/rmlvo-to-kccgst \
- test/print-compiled-keymap
+ test/print-compiled-keymap \
+ test/bench-key-proc
EXTRA_DIST = \
test/data \