summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2012-07-12 14:15:08 +0100
committerDaniel Stone <daniel@fooishbar.org>2012-07-12 14:48:22 +0100
commit3e86ebca0684d90899f34c2add6b1474c464613f (patch)
tree99fb64a1832fbe82915f0655ad53218217085635 /Makefile.am
parent059c1842ef35aa6e2eb33230a228edb12ecd8852 (diff)
Add a library of common test functions
Including creating a context (will come in useful soon), opening and reading files, and compiling keymaps. Signed-off-by: Daniel Stone <daniel@fooishbar.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index a8ec13d..a2fe5ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,9 +108,11 @@ $(top_builddir)/makekeys/makekeys$(EXEEXT): $(top_srcdir)/makekeys/makekeys.c
# Some tests need to use unexported symbols, so we link them against
# a private copy of libxkbcommon with all symbols exposed.
-noinst_LTLIBRARIES = libxkbcommon-priv.la
-libxkbcommon_priv_la_LDFLAGS = $(libxkbcommon_la_LDFLAGS)
-libxkbcommon_priv_la_SOURCES = $(libxkbcommon_la_SOURCES)
+noinst_LTLIBRARIES = libtest.la
+libtest_la_LDFLAGS = $(libxkbcommon_la_LDFLAGS)
+libtest_la_SOURCES = \
+ $(libxkbcommon_la_SOURCES) \
+ test/common.c
TESTS_ENVIRONMENT =
@@ -126,7 +128,7 @@ TESTS = \
test/dump \
test/stringcomp \
test/keyseq
-TESTS_LDADD = libxkbcommon-priv.la
+TESTS_LDADD = libtest.la
test_xkey_LDADD = $(TESTS_LDADD)
test_filecomp_LDADD = $(TESTS_LDADD)
@@ -143,7 +145,9 @@ test_keyseq_LDADD = $(TESTS_LDADD)
check_PROGRAMS = $(TESTS)
-EXTRA_DIST = test/data
+EXTRA_DIST = \
+ test/data \
+ test/test.h
# This sed script strips out lines that start with '#define _' which
# removes #define _OSF_Keysyms and such. The XK_Ydiaeresis case is to