summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 619ca39..a4ece27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,11 +27,15 @@ AC_INIT(lbxutil, 1.0.1, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
AM_CONFIG_HEADER(config.h)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
+XORG_CWARNFLAGS
# Check for X
PKG_CHECK_MODULES(LBXUTIL, xextproto xproto)
@@ -39,6 +43,7 @@ PKG_CHECK_MODULES(LBXUTIL, xextproto xproto)
AC_CHECK_LIB(z,deflate,[LBXUTIL_LIBS="${LBXUTIL_LIBS} -lz"],
AC_MSG_ERROR([zlib is required to build liblbxutil]))
+LBXUTIL_CFLAGS="$CWARNFLAGS $LBXUTIL_CFLAGS"
AC_SUBST(LBXUTIL_CFLAGS)
AC_SUBST(LBXUTIL_LIBS)
@@ -46,6 +51,7 @@ AC_SUBST(LBXUTIL_LIBS)
# find the required protocol version
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile
src/Makefile