summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:48 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:48 -0500
commitcfd82b1ff1033dbb3d83fd71e8b1af5535108245 (patch)
tree91bdf131ed8b3d77a1928ac43949db97096d7edf /Makefile.am
parenta49ce3a7f23e0bfab84661afea15602403445c5a (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e52fe5..43b136e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,3 +26,13 @@ pkgconfig_DATA = dmx.pc
EXTRA_DIST = dmx.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog