summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 17 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 6578e7b..a02451e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,27 +1,30 @@
-AC_PREREQ([2.60])
+# Initialize Autoconf
+AC_PREREQ([2.60])
AC_INIT([libXxf86vm], [1.1.1],
- [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- [libXxf86vm])
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXxf86vm])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS(src/config.h)
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Initialize libtool
+AC_PROG_LIBTOOL
+
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AC_CONFIG_HEADERS(src/config.h)
-
-# Check for progs
-AC_PROG_LIBTOOL
+XORG_CHECK_MALLOC_ZERO
-# Checks for pkg-config packages
+# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XXF86VM, xproto x11 xextproto xext [xf86vidmodeproto >= 2.2.99.1])
-XORG_CHECK_MALLOC_ZERO
-
-AC_OUTPUT([Makefile
- src/Makefile
- man/Makefile
- xxf86vm.pc])
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ man/Makefile
+ xxf86vm.pc])
+AC_OUTPUT