summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:46 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:46 -0500
commitb3b1c2f578fd68b3cea689876acf68807e2cb03a (patch)
tree0bb3e5e5f8082e2f1127012c82c329bafb520457 /Makefile.am
parentf4ed7977e3bd5a60df0d5df089a613462c04dc3f (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cdfbd95..d80a181 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,3 +4,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xxf86misc.pc
EXTRA_DIST = xxf86misc.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog