summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-07-05 21:19:29 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-07-05 21:19:29 -0700
commit4a7d2ca2438649e61b7dcb9491391ff6fbd482ac (patch)
tree7d9e4b02ed9a45f7acbff408d51ecb3c00c97445 /configure.ac
parent06d275959b5dd78c319d5200ca6d986934b18920 (diff)
Remove fallback for _XEatDataWords, require libX11 1.6 for it
_XEatDataWords was orignally introduced with the May 2013 security patches, and in order to ease the process of delivering those, fallback versions of _XEatDataWords were included in the X extension library patches so they could be applied to older versions that didn't have libX11 1.6 yet. Now that we're past that hurdle, we can drop the fallbacks and just require libX11 1.6 for building new versions of the extension libraries. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 93c326d..c154f1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,13 +41,7 @@ XORG_DEFAULT_OPTIONS
XORG_CHECK_MALLOC_ZERO
# Obtain compiler/linker options for depedencies
-PKG_CHECK_MODULES(XV, [x11 >= 1.5 xext xextproto videoproto])
-
-# Check for _XEatDataWords function that may be patched into older Xlib release
-SAVE_LIBS="$LIBS"
-LIBS="$XV_LIBS"
-AC_CHECK_FUNCS([_XEatDataWords])
-LIBS="$SAVE_LIBS"
+PKG_CHECK_MODULES(XV, [x11 >= 1.6 xext xextproto videoproto])
# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT