summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-05-21 20:47:26 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-05-21 20:47:26 +0000
commit2e00049e9b02e26f858c3e4510641a735c03b086 (patch)
tree34158cbecc6805a46678cdc1f113e5d4272e42d3 /Makefile.am
parenta175c9ea92967441a7ad33d2f6c8bf26cbe954fe (diff)
Use $(install_sh_DATA) instead of "install" for better portability. Remove
duplicate installation lines. Add AM_CFLAGS to pass through XT_CFLAGS & X11_CFLAGS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d87739..a18d331 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,9 +52,7 @@ all-local: $(BUILT_FILES)
$(BUILT_FILES):
$(top_builddir)/util/makestrs $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
- install StringDefs.c $(top_builddir)/src
- install $(top_builddir)/StringDefs.h $(top_builddir)/include/X11/
- install $(top_builddir)/Shell.h $(top_builddir)/include/X11/
- install -m644 $(top_builddir)/StringDefs.h $(top_builddir)/include/X11/
- install -m644 $(top_builddir)/Shell.h $(top_builddir)/include/X11/
+ $(install_sh_DATA) StringDefs.c $(top_builddir)/src
+ $(install_sh_DATA) $(top_builddir)/StringDefs.h $(top_builddir)/include/X11/
+ $(install_sh_DATA) $(top_builddir)/Shell.h $(top_builddir)/include/X11/