summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2006-12-06 18:54:24 +0200
committerDaniel Stone <daniels@endtroducing.fooishbar.org>2006-12-06 18:54:24 +0200
commitb834a33035b0192b4213ff1d6198045b74ab65fe (patch)
treea1502aea097868e48bc256473ace373221846676 /Makefile.am
parentdbf918f5a95b73bd9652d520bb36eedee772c940 (diff)
Makefile.am: make ChangeLog hook safer
Make ChangeLog hook as safe as possible
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b845b54..8661f3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,7 @@ EXTRA_DIST = xfontcache.pc.in autogen.sh ChangeLog
CLEANFILES = ChangeLog
-ChangeLog: FORCE
- git-log > ChangeLog
-FORCE:
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog