summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-08-11 14:22:42 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-08-11 14:22:42 -0700
commita106f489a69246f24535acd8bdac96e273df7334 (patch)
tree9e72303c16724b3a9ee77d07ef0b74664a5b6db9 /Makefile.am
parent644ff9232d48a32dcc16a1eeba2b51c8686eb33e (diff)
Replace static ChangeLog with dist-hook to generate from git-log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fd2e96..62d6a3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,3 +79,12 @@ lintlib_DATA = $(LINTLIB)
$(LINTLIB): $(libXdmcp_la_SOURCES) $(nodist_libXdmcp_la_SOURCES)
$(LINT) -y -oXdmcp -x $(ALL_LINT_FLAGS) $(libXdmcp_la_SOURCES) $(nodist_libXdmcp_la_SOURCES)
endif MAKE_LINT_LIB
+
+if MAINTAINER_MODE
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log > ChangeLog
+
+dist-hook: ChangeLog
+endif MAINTAINER_MODE