summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:25 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:25 -0500
commit94531dc8f6eff9c9f5cbb18ca6b3d4ff79eec752 (patch)
tree6fcefc5dbf813b02f6ea3876ea5bec92b14ce420 /Makefile.am
parenta4f29e6deef2bf46cae811aaac1f535945cd9fee (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0050eb2..21da648 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,3 +34,13 @@ if LINT
lint:
(cd src && $(MAKE) $(MFLAGS) lint)
endif LINT
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog