summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 57d5dc6..f8a7f50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
-# Initialize Autoconf
-AC_PREREQ([2.60])
+# Initialize Autoconf - requires at least 2.64 for m4_version_prereq
+AC_PREREQ([2.64])
AC_INIT([libXaw3d], [1.6.4],
[https://gitlab.freedesktop.org/xorg/lib/libxaw3d/-/issues], [libXaw3d])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -27,7 +27,7 @@ if test ! -f "$srcdir/src/laygram.c"; then
AC_MSG_ERROR([yacc not found - unable to compile laygram.y])
fi
fi
-AC_PROG_LEX
+m4_version_prereq([2.70], [AC_PROG_LEX(noyywrap)], [AC_PROG_LEX])
AC_PATH_PROG([LEX_INST], $LEX)
if test ! -f "$srcdir/src/laylex.c"; then
if test -z "$LEX_INST"; then