summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
new file mode 100644
index 0000000..003e9be
--- /dev/null
+++ b/man/meson.build
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: MIT
+# Copyright © 2023 Intel Corporation
+
+prog_sed = find_program('sed')
+
+foreach man : ['Xau', 'XauDisposeAuth', 'XauFileName', 'XauGetAuthByAddr',
+ 'XauGetBestAuthByAddr', 'XauLockAuth', 'XauReadAuth', 'XauUnlockAuth',
+ 'XauWriteAuth']
+ custom_target(
+ f'@man@.man',
+ input : f'@man@.man',
+ output : f'@man@.3',
+ command : [
+ prog_sed, '@INPUT@',
+ '-e', 's/__xorgversion__/"libXau @0@" "X Version 11"/'.format(meson.project_version()),
+ '-e', 's/__libmansuffix__/3/',
+ ],
+ capture : true,
+ install : true,
+ install_dir : get_option('prefix') / get_option('mandir') / 'man3',
+ )
+endforeach \ No newline at end of file