summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-25 21:47:56 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-25 21:47:56 +0000
commit3a9234d968568f2009376cdb219ea47b90572c68 (patch)
tree7261d6adda577b97c1d54e29b19f8dfa3d8c6c90 /Makefile.am
parentf4a1380add427a6ed7a0025d5acd5642c683900e (diff)
- Add FSlib to symlink.shXORG-6_8_99_9XORG-6_8_99_10
- Change Xtrans includedir back to be X11/Xtrans, so that users of it can continue to include <X11/*> - Add build system for FSlib - Conditionally include config.h in xc/lib/FS - Remove redundant include of FSproto.h in xc/lib/FS - Add check to proto/X11/configure.ac whether -D_XOPEN_SOURCE is needed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f09a9be
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+#
+# $Id$
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+SUBDIRS = src
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libfs.pc
+
+EXTRA_DIST = libfs.pc.in autogen.sh