summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 20:13:48 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 20:13:48 -0700
commit7f8f1ccefe2af7677a79ecaeba128856f7ec7b76 (patch)
tree5070dfc0c0145b43ce6c2be672fbd63fc07f4461 /configure.ac
parent409af7daa6393b96747c7a26573916fc7ea56651 (diff)
Migrate to xorg macros 1.3 & font-util 1.1 macros
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 11 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index c5852a5..3a7ed30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,29 +25,20 @@ AC_PREREQ([2.57])
AC_INIT(font-xfree86-type1, [1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], font-xfree86-type1)
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
-# Require xorg-macros: XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
AC_PROG_INSTALL
-AC_PATH_PROG(MKFONTSCALE, mkfontscale)
-if test x"$MKFONTSCALE" = x; then
- AC_MSG_ERROR([mkfontscale is required to build xfree86-type1 fonts.])
-fi
-AC_PATH_PROG(MKFONTDIR, mkfontdir)
-if test x"$MKFONTDIR" = x; then
- AC_MSG_ERROR([mkfontdir is required to build xfree86-type1 fonts.])
-fi
-AC_PATH_PROG(FCCACHE, fc-cache)
+# Require X.Org's font util macros 1.1 or later
+m4_ifndef([XORG_FONT_MACROS_VERSION],
+ [m4_fatal([must install X.Org font-util 1.1 or later before running autoconf/autogen])])
+XORG_FONT_MACROS_VERSION(1.1)
-fontdir=${libdir}/X11/fonts/Type1
-AC_ARG_WITH(fontdir, AC_HELP_STRING([--with-fontdir=<pathname>],
- [Path to install fonts]), [fontdir="$withval"])
-FONTDIR="$fontdir"
-AC_SUBST(FONTDIR)
-
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
+XORG_FONTDIR([Type1])
+XORG_FONT_SCALED_UTILS
AC_OUTPUT([Makefile])