summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-11-15 08:29:20 +0000
committerKevin E Martin <kem@kem.org>2005-11-15 08:29:20 +0000
commit5862795a77587055486b4d247bd609ae82747a37 (patch)
tree187864495741b0023c3f7b6424d7a5b6df1a24da /configure.ac
parent7c5aebd7505781252ffba64accdd396a2e37096c (diff)
Add configure option to change the installed font dir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d6db913..15b7106 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,13 @@ AM_MAINTAINER_MODE
AC_PROG_INSTALL
+DEFAULT_FONTDIR=${libdir}/X11/fonts/Type1
+AC_ARG_WITH(fontdir,
+ AS_HELP_STRING([--with-fontdir=FONTDIR], [Path to install fonts]),
+ [FONTDIR="$withval"],
+ [FONTDIR="$DEFAULT_FONTDIR"])
+AC_SUBST(FONTDIR)
+
AC_PATH_PROG(MKFONTSCALE, mkfontscale)
AC_PATH_PROG(MKFONTDIR, mkfontdir)
AC_PATH_PROG(FCCACHE, fc-cache)