summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 20:04:59 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 20:04:59 -0700
commited92e73073b7bc73d384f03fbee5102e5aaee3c2 (patch)
tree30ce3044b85883ee25470a7fc9490976c36470d6 /Makefile.am
parent19ea2388dbb79584a7f90b938ca76e4b05b91461 (diff)
Migrate to xorg macros 1.3 & font-util 1.1 macros
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 12b622b..396996b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,13 +27,13 @@ FONT_FILES = \
olgl19
BDF_FILES = $(FONT_FILES:%=%.bdf)
-PCF_FILES = $(FONT_FILES:%=%.pcf.gz)
+PCF_FILES = $(FONT_FILES:%=%.pcf$(COMPRESS_SUFFIX))
-SUFFIXES = .bdf .pcf.gz
+SUFFIXES = .bdf .pcf$(COMPRESS_SUFFIX)
-.bdf.pcf.gz:
+.bdf.pcf$(COMPRESS_SUFFIX):
@rm -f $@
- $(BDFTOPCF) -t $< | gzip > $@
+ $(AM_V_GEN)$(BDFTOPCF) -t $< | $(COMPRESS) > $@
fontdir = @FONTDIR@
font_DATA = $(PCF_FILES)
@@ -42,10 +42,9 @@ CLEANFILES = $(font_DATA)
EXTRA_DIST = $(BDF_FILES) autogen.sh
install-data-hook:
- @rm -f $(DESTDIR)$(fontdir)/fonts.scale
- $(MKFONTSCALE) $(DESTDIR)$(fontdir)
@rm -f $(DESTDIR)$(fontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(fontdir)
+ @RUN_FCCACHE@
distuninstallcheck:
@: