summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 19:36:43 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 19:36:43 -0700
commit25dee300d5cd15a16e16c2584265daa6336294fb (patch)
treef55d57720fa6aacbd49df63252ef44fa70eb18c2 /configure.ac
parentca90ff97738322776ed18d4a13b5bcef1741b513 (diff)
Migrate to xorg macros 1.3 & font-util 1.1 macros
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 11 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 8ff8e7a..e10959b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,32 +26,20 @@ AC_INIT(font-mutt-misc, [1.0.0], [https://bugs.freedesktop.org/enter_bug.cgi?pro
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_RELEASE_VERSION XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
AC_PROG_INSTALL
-AC_PATH_PROG(BDFTOPCF, bdftopcf)
-AC_PATH_PROG(MKFONTSCALE, mkfontscale)
-if test x"$MKFONTSCALE" = x; then
- AC_MSG_ERROR([mkfontscale is required to build mutt-misc fonts.])
-fi
-AC_PATH_PROG(MKFONTDIR, mkfontdir)
-if test x"$MKFONTDIR" = x; then
- AC_MSG_ERROR([mkfontdir is required to build mutt-misc fonts.])
-fi
+# Require X.Org's font util macros 1.1 or later
+m4_ifndef([XORG_FONT_MACROS_VERSION],
+ [m4_fatal([must install X.Org font-util 1.1 or later before running autoconf/autogen])])
+XORG_FONT_MACROS_VERSION(1.1)
-m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
-
-DEFAULT_FONTDIR=${libdir}/X11/fonts/misc
-AC_ARG_WITH(fontdir,
- AS_HELP_STRING([--with-fontdir=FONTDIR], [Path to install fonts]),
- [FONTDIR="$withval"],
- [FONTDIR="$DEFAULT_FONTDIR"])
-AC_SUBST(FONTDIR)
-
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
+XORG_FONTDIR([misc])
+XORG_FONT_BDF_UTILS
AC_OUTPUT([Makefile])