summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-27 19:11:08 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-27 19:11:08 -0200
commit36a7c774bd10b5e5466e9c029a348595590fd978 (patch)
tree0b50f98bc0b8a0a98c9830da953ef9575cb98b32 /configure.ac
parent8034d7b20d1fe9adf5c15c6c0d9c2e1f1d19f79a (diff)
Janitor: Correct make distcheck and configure.ac simplification
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 0cef0bf..97ac47d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,9 @@ AC_INIT(font-misc-misc, [1.0.0], [https://bugs.freedesktop.org/enter_bug.cgi?pro
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
AC_PROG_INSTALL
AC_PATH_PROGS(PERL, perl perl5)
@@ -41,14 +44,10 @@ if test x"$MKFONTDIR" = x; then
AC_MSG_ERROR([mkfontdir is required to build misc-misc fonts.])
fi
-
-m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
-
-DEFAULT_FONTDIR=${libdir}/X11/fonts/misc
-AC_ARG_WITH(fontdir,
- AS_HELP_STRING([--with-fontdir=FONTDIR], [Path to install fonts]),
- [FONTDIR="$withval"],
- [FONTDIR="$DEFAULT_FONTDIR"])
+fontdir=${libdir}/X11/fonts/misc
+AC_ARG_WITH(fontdir, AC_HELP_STRING([--with-fontdir=<pathname>],
+ [Path to install fonts]), [fontdir="$withval"])
+FONTDIR="$fontdir"
AC_SUBST(FONTDIR)
PKG_CHECK_MODULES(MAPS, [fontutil])
@@ -73,5 +72,6 @@ XORG_FONT_CHECK_KOI8_R
XORG_FONT_CHECK_JISX0201
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile])