summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..761a183
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software
+# and its documentation for any purpose is hereby granted without
+# fee, provided that the above copyright notice appear in all copies
+# and that both that copyright notice and this permission notice
+# appear in supporting documentation, and that the name of Red Hat
+# not be used in advertising or publicity pertaining to distribution
+# of the software without specific, written prior permission. Red
+# Hat makes no representations about the suitability of this software
+# for any purpose. It is provided "as is" without express or implied
+# warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+ttffontdir = $(libdir)/X11/fonts/TTF
+ttffont_DATA = GohaTibebZemen.ttf
+
+otffontdir = $(libdir)/X11/fonts/OTF
+otffont_DATA = GohaTibebZemen.otf
+
+EXTRA_DIST = $(ttffont_DATA) $(otffont_DATA) license.txt autogen.sh
+
+install-data-hook:
+ @rm -f $(DESTDIR)$(ttffontdir)/fonts.scale
+ $(MKFONTSCALE) $(DESTDIR)$(ttffontdir)
+ @rm -f $(DESTDIR)$(ttffontdir)/font.dir
+ $(MKFONTDIR) $(DESTDIR)$(ttffontdir)
+ $(FCCACHE) $(DESTDIR)$(ttffontdir)
+ @rm -f $(DESTDIR)$(otffontdir)/fonts.scale
+ $(MKFONTSCALE) $(DESTDIR)$(otffontdir)
+ @rm -f $(DESTDIR)$(otffontdir)/font.dir
+ $(MKFONTDIR) $(DESTDIR)$(otffontdir)
+ $(FCCACHE) $(DESTDIR)$(otffontdir)
+
+distuninstallcheck:
+ @: