summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d0e24cb..c979e70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,12 +32,30 @@ install-data-hook:
$(MKFONTSCALE) $(DESTDIR)$(ttffontdir)
@rm -f $(DESTDIR)$(ttffontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(ttffontdir)
- $(FCCACHE) $(DESTDIR)$(ttffontdir)
+ @(if `test -z '$(DESTDIR)'`; then \
+ echo $(FCCACHE) $(ttffontdir); \
+ $(FCCACHE) $(ttffontdir); \
+ else \
+ echo "***"; \
+ echo "*** Warning: fonts.cache not built"; \
+ echo "***"; \
+ echo "*** Generate this file manually on host system using fc-cache"; \
+ echo "***"; \
+ fi)
@rm -f $(DESTDIR)$(otffontdir)/fonts.scale
$(MKFONTSCALE) $(DESTDIR)$(otffontdir)
@rm -f $(DESTDIR)$(otffontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(otffontdir)
- $(FCCACHE) $(DESTDIR)$(otffontdir)
+ @(if `test -z '$(DESTDIR)'`; then \
+ echo $(FCCACHE) $(otffontdir); \
+ $(FCCACHE) $(otffontdir); \
+ else \
+ echo "***"; \
+ echo "*** Warning: fonts.cache not built"; \
+ echo "***"; \
+ echo "*** Generate this file manually on host system using fc-cache"; \
+ echo "***"; \
+ fi)
distuninstallcheck:
@: