summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-02-22 13:01:54 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-02-22 13:01:54 -0800
commitb37ac72744d42a27d22741b5b1220c8a597b655b (patch)
tree1a6cc02ace202ea803a795bc2051d3c3004393e8 /configure.ac
parente40356cf6bcbea6966d5a2c98ca767e07b3e7aa8 (diff)
configure: Add COMPRESS_FLAGS to pass options to compression command
By default, set to -n for gzip to stop recording timestamps and improve build reproducibility. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a51b8ca..c9e40f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,8 @@ if test x$GZIP_SMALL = xyes -o x$GZIP_LARGE = xyes ; then
if [[ -z $GZIP ]]; then
AC_MSG_ERROR([gzip is needed to compress font encodings])
fi
+ COMPRESS_FLAGS="${COMPRESS_FLAGS--n}"
+ AC_SUBST([COMPRESS_FLAGS])
fi
XORG_FONTSUBDIR([ENCODINGSDIR], [encodingsdir], [encodings])