summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-10-20 14:51:51 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-10-20 14:51:51 -0700
commit018b3e3ccceb266ce32351ef1a71a499e149422b (patch)
treec2135397856e446cc45a730f0d817d37caaef40a /Makefile.am
parent1826bdeed2a06857179a3d4dce516d9d91bd22bc (diff)
Add --disable-gzip-{small,large}-encoding flags to configure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 188013e..1abfce5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,16 +42,24 @@ EXTRA_DIST = $(ENCODING_FILES) ChangeLog
COMPRESSED = $(ENCODING_FILES:%=%.gz)
+CLEANFILES = encodings.dir
+
+if GZIP_SMALL
+DATA_FILES = $(COMPRESSED)
+CLEANFILES += $(COMPRESSED)
+else
+DATA_FILES = $(ENCODING_FILES) encodings.dir
+endif
+
SUFFIXES = .enc .enc.gz
.enc.enc.gz:
@GZIP@ -c < $< > $@
-encodings.dir:
+encodings.dir: $(DATA_FILES)
@MKFONTSCALE@ -b -s -l -n -r -p $(encodingsdir) -e . -e large .
-encodings_DATA = $(COMPRESSED) encodings.dir
-CLEANFILES = $(COMPRESSED) encodings.dir
+encodings_DATA = $(DATA_FILES) encodings.dir
MAINTAINERCLEANFILES=ChangeLog