summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 16:29:13 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-07 16:29:13 -0700
commitfbd4afe7b79e8dd6d06232fb1a98f2bb79f8ab72 (patch)
tree73f86eab9f4d853001eaf6458ca698ee955935db /Makefile.am
parentea291e10f50f1588d27bce83a58257a75d7733b9 (diff)
Migrate to xorg macros 1.3 & font-util 1.1 macros
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 626a9c7..615716f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,13 +25,13 @@ FONT_FILES = \
hanglm24
BDF_FILES = $(FONT_FILES:%=%.bdf)
-PCF_FILES = $(FONT_FILES:%=%.pcf.gz)
+PCF_FILES = $(FONT_FILES:%=%.pcf$(COMPRESS_SUFFIX))
-SUFFIXES = .bdf .pcf.gz
+SUFFIXES = .bdf .pcf$(COMPRESS_SUFFIX)
-.bdf.pcf.gz:
+.bdf.pcf$(COMPRESS_SUFFIX):
@rm -f $@
- $(BDFTOPCF) -t $< | gzip > $@
+ $(AM_V_GEN)$(BDFTOPCF) -t $< | $(COMPRESS) > $@
fontdir = @FONTDIR@
font_DATA = $(PCF_FILES)
@@ -40,10 +40,9 @@ CLEANFILES = $(font_DATA)
EXTRA_DIST = $(BDF_FILES)
install-data-hook:
- @rm -f $(DESTDIR)$(fontdir)/fonts.scale
- $(MKFONTSCALE) $(DESTDIR)$(fontdir)
@rm -f $(DESTDIR)$(fontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(fontdir)
+ @RUN_FCCACHE@
distuninstallcheck:
@: