summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:54 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:54 -0500
commit1191e659159879ac1ecc09608f6da2e74380a2c7 (patch)
treeac1230b734adfa379b79b695013aa61783f4baca /Makefile.am
parentffbdefb48cd67e4404aa2d6f2f1be12d916f5113 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f377964..86dc503 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,3 +108,13 @@ install-data-hook:
distuninstallcheck:
@:
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog